Was ist neu?

Kunde kann sich nicht einlogen

Tiburon

- Premium Member -
Habe ein Problem mit einer Webseite von mir.

Die Webseite wird mit Netdebit abgerechnet. Bis jetzt noch Nie Probleme gehabt, bis mich gestern Netdebit angeschrieben hat, dass ein Kunde sind nicht einlogen kann.

Er wurde ohne Probleme angelegt. Habe es selber getestet. Anlegen kein Thema, nur einlogen geht nicht.

Hat einer eine Idee warum?

Gruss Tiburon
 

Tiburon

- Premium Member -
Die Codes sind richtig.

Als Fhelermeldung bekomme Ich das hier: This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.
 

Globi

- Premium Member -
benutze mal ein anderen browser, oder zb firefox im privaten modus.

loesche cookies

ansonsten

überpruefe mal ob die .htaccess und .htpasswd existieren, und wenn was da drin steht, ob zb ein pw vorhanden ist (ist dann meist verschluesselt)

ansonsten schwierig ne ferndiagnose zu machen, aber mus damit zu tun haben.
 

thommy

- Premium Member -
Die Codes sind richtig.

Als Fhelermeldung bekomme Ich das hier: This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.


hast DU username und password ausprobiert oder schreibt das der kunde?

steht der kunde in deiner htpasswd oder DB drin? netdebit versucht das nämlich nicht mehrfach. wenn da einmal ein connect nicht klappt bleibt der user draussen.

dann kommt natürlich noch die frage ob er überhaupt zu ner pw- abfrage kommt, denn das ist bei vielen kunden so, dass diese gar nicht erscheint, weil sie mit ihren internetoptionen rumspielen.

wundert mich übrigens, dass du "noch nie" probleme damit gehabt hast. das ist einer der häufigsten fehler, die bei geschützten zugängen überhaupt auftreten. wir haben solche fälle mehrere tausend mal im jahr, daher überprüfen wir auch jede einzelne buchung auf erfolgtes login und haken nach, wenn das nicht erfolgt ist (ist viel arbeit aber spart stornos in 6-stelliger höhe pro jahr - von den kündigungen wollen wir gar nicht erst reden)

aber alleine zum thema "kunde kann nicht einloggen" hab ich hier ca. 8 DIN A4-seiten an möglichen fehlerquellen in unserer supportdatenbank.

viel spass im netz

thommy
 

thommy

- Premium Member -
benutze mal ein anderen browser, oder zb firefox im privaten modus.

loesche cookies
wenn´s über htaccess verifiziert wird, hat das doch nichts mit den cookies zu tun.

einer der weit verbreitetsen fehler hier ist, dass kunden username und pw aus der mail kopieren und dabei ein leerzeichen mit kopieren. die behaupten dann steif und fest sie haben alles richtig gemacht und wünschen dir die krätze an den hals weils an ihnen ja nicht liegt.

in 95% aller fälle ist das ein eingabefehler - in 5% liegts an anderen dingen, wie zum beispiel aktivierte anonyme anmeldung in den internetoptionen - aber da erscheint dann nicht mal ein eingabefenster.
ganz doll sind da auch macs, die bei einmal hinzugefügtem pw zum schlüsselbund keine pw.abfrage mehr bringen und immer wieder das selbe pw. eingeben auch wenns falsch ist.

viel spass im netz

thommy
 

Tiburon

- Premium Member -
erstmal danke euch beiden.

hast DU username und password ausprobiert oder schreibt das der kunde?
Habe es auch getestet - Ohne Erfolg

In dieser Datei: .NetDebit.secure steht der User mit verschlüsselten Passwort.

Aber in dieser: .newhtpasswd taucht er nicht auf.
 

Globi

- Premium Member -
ja cookies haben nix mit htaccess zu tun, aber der IE hat so ne macke, das wenn du einmal falsches pw eingiebst, das er das unbedingt behalten will, und es automatisch wieder wechselt, auch wenn du das 2te mal das richtige eingiebst.
der holt sich das zwar nicht aus dem cookie, aber das cokkie meldet dem irgendwie das er die seite schonmal besucht hat....egal, war vielleicht ne falsche ueberlegung, aber darum sagte ich zuerst mal browser wechseln.

ich denke wenn netdebit ihm sagt, der kunde kann sich nicht einlogen, haben die dem kunden schon gesagt das er evt ein leerzeichen drin hat, darum gieng ich mal davon aus, das sie das selber getestet haben, bevor sie es einem webmaster weitergeben.

also so das das problem schon bei ihm liegen muesste, und nicht beim kunden.

aber wer weis das schon bei ND :)

die fehlermeldung jedenfalls kommt ganz klar von der htaccess.
 

MikeDe

- Premium Member -
erstmal danke euch beiden.



Habe es auch getestet - Ohne Erfolg

In dieser Datei: .NetDebit.secure steht der User mit verschlüsselten Passwort.

Aber in dieser: .newhtpasswd taucht er nicht auf.
kontrollier mal die schreibrechte - bzw. schau dir mal an, wenn du einen user manuell anlegst, ob sich das datum der dateien ändert, die sich ändern müßten, und wenn sich eine nicht ändert (die sich laut Anleitung von ND ändern sollte) ob deren Schreibrechte noch passen.

wenn sich deine htaccess auf die .newhtpasswd bezieht, dann in jedem Fall mal die Schreibrechte dieser Datei kontrollieren ob das cgi/php script (je nachdem welche Variante du einsetzt) überhaupt die Datei schreiben darf.

Je nach Server und owner der Datei: 0666 z.b. als Dateirechte, manche kranke server wollen auch 0777 oder 0775
 

Steve

- Premium Member -
[OT]

aber das cokkie meldet dem irgendwie das er die seite schonmal besucht hat
Mit Verlaub ... das ist Blödsinn :D

Der Browser kann mit dem Cookie gar nichts anfangen. Die Informationen im Cookie werden von der aufrufenden Webseite ausgelesen. Der Browser sendet diese Daten auf Anfrage lediglich. Mehr nicht.

[/OT]
 

Neue Themen

Oben